Welcome to Quadratec Jeep Forum Mark forums read | View Forum Leaders
Quadratec Jeep Forum

Thread Tools Display Modes
Fresh Rebuild
Bodyman1 Bodyman1 is offline

Reply With Quote
Bodyman1 is on a distinguished road
Join Date: Apr 2012
Location: Tennessee
Posts: 1
04-01-2012, 05:11 PM
Just finished up a 4.0 in a 98 cherokee and have really sluggish throttle response up to about 1800 rpm. Then runs great. No codes are showing. Any ideas on the problem ?
austinjoe13 austinjoe13 is offline
I'm a Tooter!
austinjoe13's Avatar

Reply With Quote
austinjoe13 is on a distinguished road
Join Date: Jan 2011
Location: Grand Rapids, MN
Posts: 1,147
04-01-2012, 06:35 PM
How big are your tires? Axle gear ratio?
Emergency Medical Responder, First Responder, what have you
1990 XJ Laredo stock and fully loaded
'89 XJ Laredo lifted 2.5" on 31x10.50s
Build Thread
OhioYJ OhioYJ is offline
in-famously viral
OhioYJ's Avatar

Reply With Quote
OhioYJ will become famous soon enough
Join Date: Mar 2005
Location: Ohio
Posts: 15,277
04-01-2012, 10:41 PM
Does it start up and run/idle fine?
95 YJ: 4.0, AX15, SOA, 4" leafs, 1" shackles, 3" body, SYE, CV driveshafts, locked 44, locked 8.8, high steer w/crossover, 37x12.5's on 15x10 beadlocks, OBA, winch, and a few other things. My Build-Up Post -- Photos -- SWB FAQ -- Mike

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT -4. The time now is 04:11 AM.